Name:   Universal Desktop
 
Publisher:   Agilysys
 

This application does not support this version of Windows. Windows XP or newer is required.

This application requires Microsoft Internet Explorer or Microsoft Edge to launch or install.

The following prerequisite are required:

If the prerequisites are already installed, you can launch the application now.
Otherwise, click the links above to download the install package.
Be sure to click the Run button when prompted.
Once install(s) has completed, return to this page to launch the application.
 
  Install  
 
Agilysys Customer Support